Back to overview
Degraded
Literature Review Outage
Jul 24 at 12:50pm IST
Affected services
Website
Resolved
Jul 24 at 01:37pm IST
We identified the issue and fixed it.
Affected services
Website
Created
Jul 24 at 12:50pm IST
We are currently investigating our infra for the Outage.
Affected services
Website